You are here:--[RISOLTO] Somma in base a criteri
[RISOLTO] Somma in base a criteri2019-03-30T08:46:18+02:00

Home Forum Domande su Formule e Funzioni [RISOLTO] Somma in base a criteri

  • Autore
    Articoli
  • Avatarenea
    Partecipante
      Post totali: 6

      ciao,

      chiedo aiuto per una formula. Come spero di aver specificato nel file al link seguente, mi serve il totale degli studenti che seguono ciascun ambito di intervento, evitando di sommare i doppioni, in quanto alcune classi sono soggette a più interventi per ogni ambito, in tal caso la classe va contata una sola volta. In pratica voglio sommare le celle della colonna J in base alla presenza del criterio ambito (colonna E), senza considerare eventuali duplicati che si presentano quando la classe di quella scuola (colonna D) partecipa a più incontri sul medesimo ambito.

      Spero di essere stato chiaro…

      Grazie in anticipo

      Enea

      https://www.dropbox.com/s/bzea7vnjhglrsnm/attivit%C3%A0_scuole.xlsx?dl=0

      • Questo argomento è stato modificato 4 mesi, 2 settimane fa da sid sid.
    • sidsid
      Moderatore
        Post totali: 718

        Ciao
        Quindi hai bisogno di 3 risultati, visto che gli ambiti sono 3:
        1 – gioco
        2 – regole
        3 – affettività

        • Avatarenea
          Partecipante
            Post totali: 6

            <p style=”text-align: left;”>Esatto!</p>

        • sidsid
          Moderatore
            Post totali: 718

            Potresti sfruttare i valori dei colonna F (NUMERO DI INTERV.), e prendere in considerazione solo quelli con valore 1
            Per quanto riguarda ambito:
            gioco
            =MATR.SOMMA.PRODOTTO(--($E$2:$E$40="gioco");--($F$2:$F$40=1);$J$2:$J$40)
            regole
            =MATR.SOMMA.PRODOTTO(--($E$2:$E$40="regole");--($F$2:$F$40=1);$J$2:$J$40)
            affettività
            =MATR.SOMMA.PRODOTTO(--($E$2:$E$40="affettività");--($F$2:$F$40=1);$J$2:$J$40)

            • Avatarenea
              Partecipante
                Post totali: 6

                Potresti sfruttare i valori dei colonna F (NUMERO DI INTERV.), e prendere in considerazione solo quelli con valore 1 Per quanto riguarda ambito: gioco =MATR.SOMMA.PRODOTTO(--($E$2:$E$40="gioco");--($F$2:$F$40=1);$J$2:$J$40) regole =MATR.SOMMA.PRODOTTO(--($E$2:$E$40="regole");--($F$2:$F$40=1);$J$2:$J$40) affettività =MATR.SOMMA.PRODOTTO(--($E$2:$E$40="affettività");--($F$2:$F$40=1);$J$2:$J$40)

                grazie sid, potrebbe andare bene se non fosse che può capitare che alcune classi partecipino a più “ambiti”: in quel caso il numero di intervento sulla classe sarebbe diverso da 1 anche se si trattasse del primo incontro relativo al singolo ambito. In concreto: se in una classe vado 3 volte ma su ambiti diversi (poniamo due volte sull’ambito “gioco” e una volta sull’ambito “affettività”), nella colonna F avrei 1, 2 e 3, ma la tua formula mi considererebbe soltanto la cella relativa a 1 in F. Almeno così ho capito…

            • sidsid
              Moderatore
                Post totali: 718

                Nel file che hai postato non c’è nessuna “CLASSE&SCUOLA” che abbia più di un ambito, anche se ha avuto 3 interventi.

                Ammettendo la classe nell’immagine sottostante, se avesse un ambito intervento diverso da “gioco”, che valore metteresti in colonna F?

                • Avatarenea
                  Partecipante
                    Post totali: 6

                    come non detto, la formula funziona perfettamente in base a quanto richiesto. In risposta alla domanda di sid, con un abito diverso da “gioco” in colonna F metterei comunque 1 e in questo modo le presenze sarebbero conteggiate.

                    Ho una discordanza tra la somma dei 3 risultati delle presenze al primo incontro di ciascun ambito (come da formula di sid) e il totale degli studenti incontrati (COLONNA O) ma è ovvio, perchè quest’ultimo dato mi conteggia il singolo studente una sola volta, pertanto nel caso lo incontri su più ambiti non mi viene sommato.

                    In questo modo posso avere due informazioni distinte: il totale di studenti incontrati (colonna O) e il totale di studenti incontrati per ogni ambito (formula di sid). Quest’ultimo dato mi permette di conteggiare lo stesso studente più volte nel caso partecipi a più ambiti.

                    Che dire, grazie sid!

                • sidsid
                  Moderatore
                    Post totali: 718

                    Grazie a te per il riscontro.

                  Devi essere loggato per rispondere a questa discussione.

                  Utilizzando il sito, accetti l'utilizzo dei cookie da parte nostra. maggiori informazioni

                  Questo sito utilizza i cookie per fornire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o cliccando su "Accetta" permetti il loro utilizzo.

                  Chiudi