You are here:--[RISOLTO] Somma delle ore
[RISOLTO] Somma delle ore 2018-12-13T10:10:04+02:00

Home Forum Domande su Excel VBA e MACRO [RISOLTO] Somma delle ore

  • Autore
    Articoli
  • AvatarDOMENICO04
    Partecipante
      Post totali: 62
      #7312 |

      salve, nel file che allego, nel foglio “OTT”, perchè in G10, dove sommo BL14+BL52, mi esce 4 in vece dell’esatta somma di tutte le ore della colonna BL?
      grazie

      http://www.filedropper.com/servizio2019_1

      • Questo argomento è stato modificato 5 mesi, 1 settimana fa da sid sid.
    • sidsid
      Moderatore
        Post totali: 687

        In G10 la formula è
        =BL14+BL52
        È giusto il risultato di 4 perche entrambe le celle contengono 2

        Se te invece vuoi sommare le ore dell’intero range, devi usare la funzione SOMMA
        Esempio
        =SOMMA(BL14:BL52)

        • Questa risposta è stata modificata 6 mesi fa da sid sid.
      • AvatarDOMENICO04
        Partecipante
          Post totali: 62

          ok grazie

        • AvatarDOMENICO04
          Partecipante
            Post totali: 62

            mi servirebbe un altro aiuto sempre sullo stesso file..
            in bj14 ho messo la formula =t14
            in BK14 ho messo ora 6:00
            in BL14 ho messo =SE(BJ14-BK14=0;””;BJ14-BK14) in modo che resta vuota se il valore è 00:00
            però dovrei aggiungere a quest’ultima formula se in B14 viene messo un * sottrai 30 minuti

          • AvatarDOMENICO04
            Partecipante
              Post totali: 62

              riallego il file con le formule, tenendo presente sempre il foglio “ott” e nonostante abbia messo
              =SE(BJ14-BK14<=0;””;BJ14-BK14) compare lo stesso 00:00
              http://www.filedropper.com/servizio2019ff

            • AvatarDOMENICO04
              Partecipante
                Post totali: 62

                mi dite anche come fare per riprendere una discussione chiusa?

              • sidsid
                Moderatore
                  Post totali: 687

                  Puoi mandare un messaggio in privato all’admin o ad un moderatore.
                  metti il link della discussione che la riapro.

                • sidsid
                  Moderatore
                    Post totali: 687

                    ….e nonostante abbia messo
                    =SE(BJ14-BK14<=0;””;BJ14-BK14) compare lo stesso 00:00
                    http://www.filedropper.com/servizio2019ff

                    Strano non riesco a capire il motivo.
                    Prova a cambiare il test della funzione SE.
                    Se tu chiedi di verificare se BJ14-BK14< =0, significa che BK14 deve essere <= BJ14. Prova a impostarlo così; a me funziona Quindi la formula diventa =SE(BJ14<=BK14;"";BJ14-BK14)

                  • AvatarDOMENICO04
                    Partecipante
                      Post totali: 62

                      con questa formula se BJ14 e BK14 c’è orario 6:00 mi da in BL14 orario 2:00

                    • sidsid
                      Moderatore
                        Post totali: 687

                        In BK14 c’è il valore 6:00 (inserito a mano)
                        In BJ14 c’è la formula = T14 che restituisce 6:00
                        se in BL14 metto =SE(BJ14<=BK14;"";BJ14-BK14)a me restituisce cella vuota

                      • AvatarDOMENICO04
                        Partecipante
                          Post totali: 62

                          scusami sbagliavo io, puoi aggiungere a questa formula se in B14 c’è “*” deve sottrarre 30 minuti.

                        • sidsid
                          Moderatore
                            Post totali: 687

                            Nel caso un cui in B14 ci fosse *, e BJ14-BK14 restituisca meno di 30 minuti, allora la formula darà come risultato delle ore negative, e nella cella vedrai tutti cancelletti (####….)

                          • AvatarDOMENICO04
                            Partecipante
                              Post totali: 62

                              Questa combinazione non capiterà mai

                            • sidsid
                              Moderatore
                                Post totali: 687

                                Ammettiamo che la formula in BJ14 restituisca 6:00 (come fa adesso), e in BK14 abbiamo 5:00.
                                In BL14 verrà restituito 1:00
                                Se adesso in B14 mettiamo “*“, in automatico viene tolta mezz’ora, per effetto della formula inserita in S14.
                                Quindi in BL14 avremo 0:30

                              • AvatarDOMENICO04
                                Partecipante
                                  Post totali: 62

                                  in bk14 ci sarà sempre 6:00

                                • sidsid
                                  Moderatore
                                    Post totali: 687

                                    Ti ho già detto che la verifica per vedere se è presente l’asterisco in B14, viene fatta in S14; non hai bisogno di farla di nuovo.
                                    Questa la formula in S14
                                    =SE(E(C14="";D14="";E14="";F14="";G14="";H14="");SOMMA(P14:R14);SE(B14="*";SOMMA(P14:R14)-ORARIO(;30;);SOMMA(P14:R14)))
                                    Questa la parte che verifica la presenza dell’asterisco
                                    SE(B14="*";SOMMA(P14:R14)-ORARIO(;30;)
                                    Spero sia chiaro

                                  • AvatarDOMENICO04
                                    Partecipante
                                      Post totali: 62

                                      Ok …allora si puo chiudere la discussione.

                                      Grazie

                                    La discussione ‘[RISOLTO] Somma delle ore’ è chiusa a nuove risposte.

                                    Utilizzando il sito, accetti l'utilizzo dei cookie da parte nostra. maggiori informazioni

                                    Questo sito utilizza i cookie per fornire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o cliccando su "Accetta" permetti il loro utilizzo.

                                    Chiudi