You are here:--somma delle ore
somma delle ore 2018-11-19T16:00:47+00:00

Home Forum Domande su Excel VBA e MACRO somma delle ore

  • Autore
    Articoli
  • DOMENICO04
    Partecipante
      Post totali: 46
      #7312 |

      salve, nel file che allego, nel foglio “OTT”, perchè in G10, dove sommo BL14+BL52, mi esce 4 in vece dell’esatta somma di tutte le ore della colonna BL?
      grazie

      http://www.filedropper.com/servizio2019_1

    • sidsid
      Moderatore
        Post totali: 502

        In G10 la formula è
        =BL14+BL52
        È giusto il risultato di 4 perche entrambe le celle contengono 2

        Se te invece vuoi sommare le ore dell’intero range, devi usare la funzione SOMMA
        Esempio
        =SOMMA(BL14:BL52)

        • Questa risposta è stata modificata 2 settimane, 6 giorni fa da sid sid.
      • DOMENICO04
        Partecipante
          Post totali: 46

          ok grazie

        • DOMENICO04
          Partecipante
            Post totali: 46

            mi servirebbe un altro aiuto sempre sullo stesso file..
            in bj14 ho messo la formula =t14
            in BK14 ho messo ora 6:00
            in BL14 ho messo =SE(BJ14-BK14=0;””;BJ14-BK14) in modo che resta vuota se il valore è 00:00
            però dovrei aggiungere a quest’ultima formula se in B14 viene messo un * sottrai 30 minuti

          • DOMENICO04
            Partecipante
              Post totali: 46

              riallego il file con le formule, tenendo presente sempre il foglio “ott” e nonostante abbia messo
              =SE(BJ14-BK14<=0;””;BJ14-BK14) compare lo stesso 00:00
              http://www.filedropper.com/servizio2019ff

            • DOMENICO04
              Partecipante
                Post totali: 46

                mi dite anche come fare per riprendere una discussione chiusa?

              • sidsid
                Moderatore
                  Post totali: 502

                  Puoi mandare un messaggio in privato all’admin o ad un moderatore.
                  metti il link della discussione che la riapro.

                • sidsid
                  Moderatore
                    Post totali: 502

                    ….e nonostante abbia messo
                    =SE(BJ14-BK14<=0;””;BJ14-BK14) compare lo stesso 00:00
                    http://www.filedropper.com/servizio2019ff

                    Strano non riesco a capire il motivo.
                    Prova a cambiare il test della funzione SE.
                    Se tu chiedi di verificare se BJ14-BK14< =0, significa che BK14 deve essere <= BJ14. Prova a impostarlo così; a me funziona Quindi la formula diventa =SE(BJ14<=BK14;"";BJ14-BK14)

                  • DOMENICO04
                    Partecipante
                      Post totali: 46

                      con questa formula se BJ14 e BK14 c’è orario 6:00 mi da in BL14 orario 2:00

                    • sidsid
                      Moderatore
                        Post totali: 502

                        In BK14 c’è il valore 6:00 (inserito a mano)
                        In BJ14 c’è la formula = T14 che restituisce 6:00
                        se in BL14 metto =SE(BJ14<=BK14;"";BJ14-BK14)a me restituisce cella vuota

                      • DOMENICO04
                        Partecipante
                          Post totali: 46

                          scusami sbagliavo io, puoi aggiungere a questa formula se in B14 c’è “*” deve sottrarre 30 minuti.

                        • sidsid
                          Moderatore
                            Post totali: 502

                            Nel caso un cui in B14 ci fosse *, e BJ14-BK14 restituisca meno di 30 minuti, allora la formula darà come risultato delle ore negative, e nella cella vedrai tutti cancelletti (####….)

                          • DOMENICO04
                            Partecipante
                              Post totali: 46

                              Questa combinazione non capiterà mai

                            • sidsid
                              Moderatore
                                Post totali: 502

                                Ammettiamo che la formula in BJ14 restituisca 6:00 (come fa adesso), e in BK14 abbiamo 5:00.
                                In BL14 verrà restituito 1:00
                                Se adesso in B14 mettiamo “*“, in automatico viene tolta mezz’ora, per effetto della formula inserita in S14.
                                Quindi in BL14 avremo 0:30

                              Devi essere loggato per rispondere a questa discussione.

                              Utilizzando il sito, accetti l'utilizzo dei cookie da parte nostra. maggiori informazioni

                              Questo sito utilizza i cookie per fornire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o cliccando su "Accetta" permetti il loro utilizzo.

                              Chiudi