You are here:--correzione in formula
correzione in formula2019-09-08T10:05:36+02:00

Home Forum Domande su Formule e Funzioni correzione in formula

  • Autore
    Articoli
  • Avatargiorgioantonio
    Partecipante
      Post totali: 354

      Salve e buona giornata,

      cortesemente vorrei un aiuto su un dato in formula
      la formula è la seguente:
      =SE.ERRORE(CONFRONTA(VERO;(MATR.PRODOTTO(CONTA.SE($I$1:$L$1;$C35:V35+$Z$5);RIF.RIGA($A$1:$A$20)^0)=Z$6);0);0)

      la correzione consisterebbe in questo: :V35+$Z$5
      cioè che al v35 venisse aggiunto il numero che sta in $z$5.
      Non so se serve l’osservazione che il v35, man mano che la formula
      viene distribuita in colonna, deve avere la stessa riga di $c35.
      Cioè se la formula è in rigo 70, c70:v70+$z$5.

      Per la gradita correzione attendo e ringrazio cordialmente

      • Questo argomento è stato modificato 1 settimana, 5 giorni fa da Avatar giorgioantonio.
    • D@niloD@nilo
      Partecipante
        Post totali: 48

        Ciao

        Se condividi un file con un po’ di dati e il risultato da ottenere scritto a mano sicuramente è più facile rispondere

      • Avatargiorgioantonio
        Partecipante
          Post totali: 354

          Salve appena posso,

          cmq il problema è sia $c che $v hanno la stessa riga
          esempio $c15:$V15 solo che a v5 vorrei aggiungere
          un numero che sta in Z5 in modo tale che la formula
          quando va a leggere i dati dell’archivio prenderà in
          considerazione l’area c15:v15+10 che (esempio) sta
          in Z5.
          quindi diventerebbe c15:v25.
          Questo è tutto.
          Il motivo sta che il numero varierà a seconda di alcuni
          dati.
          Spero si possa fare Ho provato e riprovato con indiretto
          o non ho saputo mettere i dati corretti o ci vuole altro.
          Grazie dell’intervento

        • Avatargiorgioantonio
          Partecipante
            Post totali: 354

            Salve ecco il file

            https://www.dropbox.com/s/dkgjnyuh3dbd2oo/Cartel1.xlsx?dl=0

            la formula va in colonna W6 e da trascinare in giù;
            prima scrivevo Z5 invece è Z4 la cella da addizionare.
            in fondo alla formula c’è z6 e quello diventa z5

            Salve

          • D@niloD@nilo
            Partecipante
              Post totali: 48

              Buongiorno

              io non capisco l’obiettivo se spighi meglio cosa vuoi fare e SOPRATTUTTO metti i risultati da ottenere a mano (senza mettere formule che se non corrette portano solo fuori strada) magari si trova la strada giusta

            • Avatargiorgioantonio
              Partecipante
                Post totali: 354

                salve Danilo,

                proprio perchè mettevo i dati errati la fomula non funzionava
                o funzionava scorrettamente.

                Poichè ho individuato gli errori di cella e corretti sono venuto
                a capo della formula che ora funziona correttamente ed è questa:
                =SE.ERRORE(CONFRONTA(VERO;(MATR.PRODOTTO(CONTA.SE($I$1:$L$1;$C6:INDIRETTO(“V”&RIF.RIGA()+$Z$4));RIF.RIGA($A$1:$A$20)^0)=Z$5);0);0)
                Spero di spiegarmi cosa voglio dalla formula:
                c6 e v6 selezionano la sola riga con rif.riga,
                in aggiunta mettiamo che la cella Z4 e non Z5 ha il numero 10
                e aggiungendo a v6 il valore di cella Z4 diventa c6:v16.
                Cmq se nn con una formula migliore il problema l’avrei risolto.
                Mi scuso e ringrazio come sempre per l’interesse ad aiutarmi.
                Giorgioantonio

              Devi essere loggato per rispondere a questa discussione.

              Utilizzando il sito, accetti l'utilizzo dei cookie da parte nostra. maggiori informazioni

              Questo sito utilizza i cookie per fornire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o cliccando su "Accetta" permetti il loro utilizzo.

              Chiudi