You are here:Home-Domande su Formule e Funzioni-Combinazione formule conta.se e cerca.vert
Combinazione formule conta.se e cerca.vert2020-01-16T12:20:50+01:00

Home Forum Domande su Formule e Funzioni Combinazione formule conta.se e cerca.vert

Taggato: ,

Visualizzazione 3 filoni di risposte
  • Autore
    Post
    • JuriJuri
      Partecipante
        Post totali: 2

        Salve,

        vi sottopongo il mio problema: ho una tabella composta da una serie di nomi (in colonna) e una serie di date (in riga); per ciascun nome, in una specifica data, inserisco una determinata casistica (che indicherò con del testo, ad es: 1,2,3,M,N,T, o altro). Diciamo che sono dei turni.

        In una seconda tabella, per ciascun nominativo, voglio contare le singole casistiche: quante volte, per tutte le date, la casistica “1” (o “2”, o “M”, o altro) è stata assegnata a Tizio?

        Ho provato con un riferimento generico di riga: funzione “conta.se” riferita alla riga di Tizio, quindi di Caio, di Sempronio e così via. ma ovviamente è un arrangiamento poco funzionale, perché cambiando l’ordine della tabella principale, o inserendo un nuovo nominativo, saltano tutti i riferimenti.

        Ciò di cui ho bisogno quindi è di una formula che conti le diverse casistiche (conta.se) ma che sia collegata in modo univoco ad ogni specifico nominativo (cerca.vert). Purtroppo non riesco a combinare le due formule. Né so se invece ci sono soluzioni migliori e più funzionali.

        Grazie per l’attenzione.

      • BySalvBySalv
        Amministratore del forum
          Post totali: 693

          Ciao Juri, un inserisci il file con l’esempio metti nomi di fantasia solo cosi si potranno creare delle formule funzionanti.

          Inserisci anche il risultato voluto manualmente senza formule

          Ciao By Sal (8-D

          Ciao By Sal (8-)
          se ti piace la soluzione aiuta a sostenere il Forum con una DONAZIONE a piacere, Grazie

        • JuriJuri
          Partecipante
            Post totali: 2

            File di esempio

            Nel file di esempio ho ricreato la tabella principale, il calendario con i nomi e i giorni, popolato con le diverse casistiche (1,2,3,M,T, ecc.).

            Nella seconda tabella ci sono i risultati che vorrei ottenere, ossia il conteggio della ricorrenza di ciascuna casistica (1,2,3,M,T, ecc.), per ciascun nominativo.

          • BySalvBySalv
            Amministratore del forum
              Post totali: 693

              Ciao Juri, le formule sono esatte quello è il metodo giusto.

              Una sola cosa devi fare, per non avere il problema che dici cambiare nome o aggiungere persone, nella seconda tabella nella colonna dei nomi nella cells “B20” devi mettere la formula “=B4” e trascinare in basso.

              in questo modo anche se sposti un nominativo in corrispondenza avrai sempre il nominativo giusto.

              Anche se non sono molto d’accordo di inserire la seconda tabella sotto la prima perche se i nominativi aumentano vanno a coprire la seconda tabella e quindi dovrai scenderla più in basso, meglio se è di fianco.

              inoltre le formule potresti modificarle in questo modo: nella colonna “B” la formula diventerebbe

              =SE($B4= "";"";$B4)

              e nelle celle adiacenti racchiudere la formula in

              =SE($B4= "";"";Formule successive)

              Con questo metodo se non ci sono nominativi non ti riporta 0 nella cella

              inoltre se vorresti sapere poi a quante ore corrispondono, dovresti indicare in qualche cella le ore corrispondenti alla sigla esempio la sigla 1 corrisponde a 3 ore in una cella scrivi “03:00:00”

              ed infine il risultato del conta.se() lo moltiplichi per la cella resta inteso che poi la cella dovrà essere formattata ad ore, ma attenzione a scegliere il formato “37:30:55” altrimenti non ti segnerà mai più di 24 ore o il residuo delle 24 ore.

              Ciao By Sal (8-D

              Ciao By Sal (8-)
              se ti piace la soluzione aiuta a sostenere il Forum con una DONAZIONE a piacere, Grazie

          Visualizzazione 3 filoni di risposte
          • Devi essere connesso per rispondere a questo topic.