You are here:Home-Domande su Formule e Funzioni-Cercare un valore in una matrice
Cercare un valore in una matrice2020-04-24T15:27:59+02:00

Home Forum Domande su Formule e Funzioni Cercare un valore in una matrice

Taggato: 

Visualizzazione 6 filoni di risposte
  • Autore
    Post
    • Avatargiomal
      Partecipante
        Post totali: 2

        Buongiorno, ho una matrice di valori, senza intestazioni particolari ma qualora necessario potrei anche aggiungerle.
        In un altro foglio ho l’elenco di questi valori, avrei necessità, mediante una formula o una macro, di risalire all’indirizzo della cella (numero di riga;numero di colonna o lettera).
        Spero che qualcuno possa aiutarmi.

        • Questo topic è stato modificato 4 mesi, 4 settimane fa da Avatargiomal.
      • BySalvBySalv
        Amministratore del forum
          Post totali: 771

          Ciao Giomal, con Excel ce una infinità di modi per trovare un dato in una matrice, bisogna vedere qual’è la tua necessità.

          io maggiormente uso le macro per fare le ricerche.

          con le formule puoi usare il classico Cerca.Verticale() oppure Indice-Confronta.

          se inserisci un esempio con pochi dati ed il risultato che vorresti anche scritto a mano vediamo cosa si può fare.

          bye bye

           

           

          Ciao By Sal (8-)
          se ti piace la soluzione aiuta a sostenere il Forum con una DONAZIONE a piacere, Grazie

        • Avatargiomal
          Partecipante
            Post totali: 2

            Grazie, ecco il link al file di esempio.

            La mia matrice è molto più grande ma il concetto è quello.

            https://www.dropbox.com/s/b7uh6w3yrdcvfls/ESEMPIO.xlsx?dl=0

          • BySalvBySalv
            Amministratore del forum
              Post totali: 771

              Ciao ecco, il risultato, ho aggiunto una colonna per il range, la colonna la da in numero, ma se vuoi la lettera posso anche darti la lettera.

              [/url]

              questo il file con la macro, guarda che fa la ricerca in tutto il foglio matrice se vuoi un range particolare bisogna inserirlo, modificando la macro, ma è facile, nel caso ti spiego come fare.

              il link al file

              http://www.filedropper.com/esempio1

              bye bye

               

               

              Ciao By Sal (8-)
              se ti piace la soluzione aiuta a sostenere il Forum con una DONAZIONE a piacere, Grazie

            • Avatarninai
              Partecipante
                Post totali: 2

                Ciao a tutta la comunità

                 

                una versione con formule potrebbe essere:

                in B2:

                =MATR.SOMMA.PRODOTTO((MATRICE!$A$1:$F$7=A2)*RIF.RIGA(MATRICE!$A$1:$F$7))

                in C2:

                =MATR.SOMMA.PRODOTTO((MATRICE!$A$1:$F$7=A2)*RIF.COLONNA(MATRICE!$A$1:$F$7))

                in D2:

                =INDIRIZZO(B2;C2;1)

                ovviamente da trascinare in basso

              • BySalvBySalv
                Amministratore del forum
                  Post totali: 771

                  Ciao Ninai, che piacere leggerti, come va? tutto bene.

                  Ciao Salvatore.

                   

                  Ciao By Sal (8-)
                  se ti piace la soluzione aiuta a sostenere il Forum con una DONAZIONE a piacere, Grazie

                • sidsid
                  Moderatore
                    Post totali: 752

                    Bentornato genietto ;)

                Visualizzazione 6 filoni di risposte
                • Devi essere connesso per rispondere a questo topic.