You are here:---Rispondi a: Conversione data
Rispondi a: Conversione data2020-01-16T16:42:20+01:00

Home Forum Domande su Excel Generale Conversione data Rispondi a: Conversione data

D@niloD@nilo
Partecipante
    Post totali: 60

    Ciao

    per fare quello che chiedi (lato formule in quanto io non scrivo codice) abbiamo bisogno di due colonne di servizio una con i nomi dei fogli inseriti a mano oppure se qualcuno ti scrive una macro che quando crei un nuovo foglio il nome si incolonna e nell’altra una formula per estrapolare la data dal nome del foglio quindi in colonna N da N3 in giù metti i nomi dei fogli (chiaramente saranno in ordine crescente) in O3 da trascinare in basso

    =DATA(SINISTRA(N3;4);STRINGA.ESTRAI(N3;5;2);DESTRA(N3;2))

    in D3 da trascinare in basso

    =INDICE($O$3:$O$10;AGGREGA(14;6;RIF.RIGA($O$3:$O$10)/(($O$3:$O$10<=B3)*($O$3:$O$10<>””))-RIF.RIGA($O$3)+1;1))   formattando le celle in personalizzato aaaammgg

    in F3 da trascinare in basso

    =CERCA.VERT(E3;INDIRETTO(“‘”&TESTO(D3;”AAAAMMGG”)&”‘!A$2:B$10″);2;0)

    oppure in D3 da trascinare in basso

    =INDICE($N$3:$N$10;AGGREGA(14;6;RIF.RIGA($O$3:$O$10)/(($O$3:$O$10<=B3)*($O$3:$O$10<>””))-RIF.RIGA($O$3)+1;1))  formattando in generale

    e in F3 da trascinare in basso

    =CERCA.VERT(E3;INDIRETTO(“‘”&D3&”‘!A$2:B$10″);2;0)

    al link allegato il file con le due procedure inserite ho messo nei range fino a riga 10…li puoi allungare a piacere

     

    FILE DA SCARICARE

    Utilizzando il sito, accetti l'utilizzo dei cookie da parte nostra. maggiori informazioni

    Questo sito utilizza i cookie per fornire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o cliccando su "Accetta" permetti il loro utilizzo.

    Chiudi