You are here:---Rispondi a: [RISOLTO] Formua_1
Rispondi a: [RISOLTO] Formua_1 2019-03-25T16:43:33+02:00

Home Forum Domande su Formule e Funzioni [RISOLTO] Formua_1 Rispondi a: [RISOLTO] Formua_1

sidsid
Moderatore
    Post totali: 639

    Senza modificare il codice della udf, puoi inserire un terzo parametro nella stessa.
    Esempio per la colonna AA hai impostato un numero max di 2; ora se questo valore invece che inserirlo nella macro, lo aggiungiamo come parametro alla udf, essa diventerà dinamica.

    Devi fare 2 semplici modifiche alla udf:

    1 – l’intestazione della udf diventa
    Public Function TROVA_RIGHE(ByVal rng As Range, ByVal rArchivio As Range, ByVal nMax As Integer) As String
    Come vedi ho aggiunto il parametro nMax, che sarà il criterio max che sceglierai per ogni singola colonna in cui inserisci la udf

    2 – L’istruzione
    If n >= 2 Then
    diventa
    If n >= nMax Then

    Adessso una modifica nel foglio: nella cella AA3 (o quella che vuoi tu, ma sempre riferita alla colonna AA) inserisci 2

    in AA7 inserisci
    =SE(CONTA.NUMERI($U7:$Y7)>=2;TROVA_RIGHE($U7:$Y7;AL!$D8:$W16;$AA$3);"")

    E trascini fin dove vuoi

    ============================================
    Per la colonna BC invece, in BC3 inserisci 3, e in BC7 inserisci
    =SE.ERRORE(SE(CONTA.NUMERI($AR7:$BA7)>=3;TROVA_RIGHE($AR7:$BA7;AL!$D8:$W16;$BC$3);"");"")
    E trascini giù.

    Ora prova a cambiare il parametro di BC3; vedrai che la udf si aggiorna in automatico.
    Spero sia chiaro il funzionamento
    Aggiorna la formula nelle celle delle colonne interessate

    Utilizzando il sito, accetti l'utilizzo dei cookie da parte nostra. maggiori informazioni

    Questo sito utilizza i cookie per fornire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o cliccando su "Accetta" permetti il loro utilizzo.

    Chiudi