You are here:---Rispondi a: formua_1
Rispondi a: formua_1 2019-03-17T12:29:24+01:00

Home Forum Domande su Formule e Funzioni formua_1 Rispondi a: formua_1

sidsid
Moderatore
    Post totali: 582

    Spero di aver capito bene la tua esigenza
    Ho usato una udf
    In un modulo standard metti questo codice

    Public Function TROVA_RIGHE(ByVal rng As Range, ByVal rArchivio As Range) As String
    Dim rRiga As Range
    Dim j As Integer
    Dim sRitardo As String
    
    For j = 1 To rArchivio.Rows.Count
        Set rRiga = rArchivio.Rows(j)
        If Evaluate("=sum(--(" & rng.Address & "= transpose(" & rRiga.Address & ")))") >= 2 Then
            sRitardo = sRitardo & j & ";"
        End If
    Next j
    TROVA_RIGHE = IIf(sRitardo = vbNullString, vbNullString, Mid(sRitardo, 1, Len(sRitardo) - 1))
    
    Set rRiga = Nothing
    End Function

    In X12 inserisci
    =SE(CONTA.NUMERI(P12:T12)>=2;TROVA_RIGHE(P12:T12;A13:E57);"")
    e trascina fin dove vuoi; spero sia abbastanza veloce.

    Utilizzando il sito, accetti l'utilizzo dei cookie da parte nostra. maggiori informazioni

    Questo sito utilizza i cookie per fornire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o cliccando su "Accetta" permetti il loro utilizzo.

    Chiudi