You are here:---Rispondi a: Inserire suono dopo evento
Rispondi a: Inserire suono dopo evento 2018-08-25T09:31:34+00:00

Home Forum Domande su Excel VBA e MACRO Inserire suono dopo evento Rispondi a: Inserire suono dopo evento

BySalvBySalv
Amministratore del forum
    Post totali: 319

    Ciao Exigo, si deve creare una funzione per il suono, per far suonare file .Wav.

    eccoti un esempio di codice che ho reperito in rete.

    #If Win64 Then
        Private Declare PtrSafe Function PlaySound Lib "winmm.dll" _
            Alias "PlaySoundA" (ByVal lpszName As String, _
            ByVal hModule As LongPtr, ByVal dwFlags As Long) As Boolean
    #Else
        Private Declare Function PlaySound Lib "winmm.dll" _
            Alias "PlaySoundA" (ByVal lpszName As String, _
            ByVal hModule As Long, ByVal dwFlags As Long) As Boolean
    #End If
    Const SND_SYNC = &H0
    Const SND_ASYNC = &H1
    Const SND_FILENAME = &H20000
    Function SoundMe() As String
    'Updateby Extendoffice 20161223
        Call PlaySound("c:\windows\media\Speech On.wav", _
          0, SND_ASYNC Or SND_FILENAME)
        SoundMe = ""
    End Function

    si possono anche inserire suoni diversi, ma devi cambiare la stringa

    "c:\windows\media\Speech On.wav"

    che è quella che emette il suono, scegliendola tra le tante che si trovano nella cartella “c:\windows\media\”, scrivendo un parametro in “SoundMe()” tipo “SoundMe(err)” ed un ciclo Select case potrai cambiare il suono in base a quello che ti serve.

    quindi in una cella metterai la formula della funzione, ad esempio se in B1 supera il valore di 500 emette il suono che hai scelto con la stringa.

    quindi in una cella qualsiasi metterai la formula che fa riferimento alla cella “B1”, esempio scriverai in “G1” la seguente formula:

    =SE(B1>500;SoundMe();"")

    Ciao By Sal :bye:

    Utilizzando il sito, accetti l'utilizzo dei cookie da parte nostra. maggiori informazioni

    Questo sito utilizza i cookie per fornire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o cliccando su "Accetta" permetti il loro utilizzo.

    Chiudi