You are here:---Rispondi a: [RISOLTO] Calcolare giorni in un mese
Rispondi a: [RISOLTO] Calcolare giorni in un mese 2018-07-01T19:17:01+00:00

Home Forum Domande su Excel VBA e MACRO [RISOLTO] Calcolare giorni in un mese Rispondi a: [RISOLTO] Calcolare giorni in un mese

federico460
Partecipante
    Post totali: 23

    mi sono dimenticato la formula

    =SE.ERRORE(SE(MESE(H10+1)=MESE(H10);H10+1;"");"")

    la metti in A11 e la tiri in giù
    se hai versioni che non supportano il SE.ERRORE

    avvisa che la cambiamo

    completiamo anche la macro
    del modulo

    Sub macro1()
    Application.EnableEvents = False
      Application.ScreenUpdating = False
    Dim I As Integer
    For I = 2 To Sheets.Count
     Worksheets(I).Activate
      Range("A11:A50").ClearContents
    For DA = 10 To 8 + Day(DateSerial(Year(Cells(4, 1)), Month(Cells(4, 1)) + 1, 0))
    Range("A" & DA + 1).Value = DateAdd("d", 1, Range("A" & DA).Value)
    Next DA
    Next I
    
    Sheets("Riepilogo").Select
    Application.EnableEvents = True
      Application.ScreenUpdating = True
    End Sub
    • Questa risposta è stata modificata 5 mesi, 1 settimana fa da  federico460.

    Utilizzando il sito, accetti l'utilizzo dei cookie da parte nostra. maggiori informazioni

    Questo sito utilizza i cookie per fornire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o cliccando su "Accetta" permetti il loro utilizzo.

    Chiudi