You are here:---Rispondi a: [RISOLTO] duplicati
Rispondi a: [RISOLTO] duplicati2018-06-27T10:24:03+01:00

Home Forum Domande su Formule e Funzioni [RISOLTO] duplicati Rispondi a: [RISOLTO] duplicati

BySalvBySalv
Amministratore del forum
    Post totali: 538

    Ciao, però non so se sei tu con un altro nickname, ma è stato proposto un quesito analogo solo con meno numeri “Superenalotto” 6 numeri, al quale l’amico “DaniloFiorini” ha risposto risolvendo il problema con le formule e colonne d’appoggio.

    ti allego il file vedi se puoi adattare le sue formule al tuo Problema, questo quello che ha spiegato per le formule.

    Buongiorno a tutti
    lato formule in AE29 da trascinare fino a riga 100

    =INDICE($B$29:$G$40;QUOZIENTE(RIF.RIGA(A1)-1;6)+1;RESTO(RIF.RIGA(A1)-1;6)+1) per incolonnare tutti i numeri della tabella

    in AF29 da trascinare fino a riga 100

    =SE.ERRORE(INDICE($AE$29:$AE$100;AGGREGA(15;6;(RIF.RIGA($AE$29:$AE$100)/(CONTA.SE($AE$29:$AE$100;$AE$29:$AE$100)>1))-RIF.RIGA($AE$29)+1;RIF.RIGA($A1)));””) per estrarre i numeri con frequenza maggiore di 1

    in AG29 da trascinare fino a riga 100

    =SE.ERRORE(INDICE($AF$29:$AF$100;CONFRONTA(0;INDICE(CONTA.SE($AG$28:AG28;$AF$29:$AF$100&””););0));””) per estrarre gli univoci di questi doppi

    in I29 da trascinare a destra e poi in basso

    =SE(VAL.DISPARI(RIF.COLONNA(I28));SE.ERRORE(INDICE($AG$29:$AG$100;SOMMA(RIF.COLONNA(A$1)*6-5;RIF.RIGA($A1)-1));””);SE(MATR.SOMMA.PRODOTTO(($AF$29:$AF$100=H29)*($AF$29:$AF$100<>“”))=0;””;MATR.SOMMA.PRODOTTO(($AF$29:$AF$100=H29)*($AF$29:$AF$100<>“”))))

    il link al file
    https://mega.nz/#!NJc3UaaD!ZJcKUJ56VgWxDXrszqvh0wnDdsuRTVFplyxWJhkM8gM

    Ciao By Sal :bye:

    P.S.Attenzione! che conta i doppioni dell’intero Range di numeri non riga per riga.

    Utilizzando il sito, accetti l'utilizzo dei cookie da parte nostra. maggiori informazioni

    Questo sito utilizza i cookie per fornire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o cliccando su "Accetta" permetti il loro utilizzo.

    Chiudi